Problem with mixed charsets

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with mixed charsets

Vladimir Gorpenko
Hello!

We are using RC 1.1.4.
I understand that this is an old version, and it is not supported. I ask
you to see my questions at the end of the letter.

A problem was detected with Symantec Endpoint Protection (SEP) reports.

The old version of the SEP generated reports in the form of letters with
an attached file, and the attached file was supplied in a base64 coding.
This worked fine.

The new version forms reports in the form of a multipart letter with
directly included HTML code.
In this case, for the letter as a whole, the charset is not specified.

The first part of the letter has such headings:
Content-Type: text/plain;charset=UTF-8
Content-Transfer-Encoding: base64

The second part of the letter has such headings:
Content-Type: text/html; charset=Cp1251;
        name="=?UTF-8?B?0JXQttC10LTQvdC10LLQvdGL0Lkg0LjRgtC+0LPQvtCy0Ys=?=
  =?UTF-8?B?0Lkg0L7RgtGH0LXRgiDQtNC70Y8g0LDQtNC80LjQvdC4?=
 
=?UTF-8?B?0YHRgtGA0LDRgtC+0YDQsF8xMS4wNy4yMDE4IDctMDAtMjEgNDg3Lmh0bWw=?="
Content-Transfer-Encoding: quoted-printable
Content-Disposition: attachment;
        filename="=?UTF-8?B?0JXQttC10LTQvdC10LLQvdGL0Lkg0LjRgtC+0LPQvtCy0Ys=?=
  =?UTF-8?B?0Lkg0L7RgtGH0LXRgiDQtNC70Y8g0LDQtNC80LjQvdC4?=
 
=?UTF-8?B?0YHRgtGA0LDRgtC+0YDQsF8xMS4wNy4yMDE4IDctMDAtMjEgNDg3Lmh0bWw=?="
Content-ID: 654=52=K9 8B>3>2K9 >BG5B 4;O 04<8=8AB@0B>@0_11.07.2018
7-00-21 487.html

RC correctly displays the body of the letter, that is, the first part.
Also, the RC shows that there is an attached file of type xml.

However, the RC does not correctly save this attached file and, as a
consequence, incorrectly opens it.
First, the size of saved file is about a quarter less than the attached
one.
Secondly, in content, it sharply differs from the same file saved from
the same letter with the help of Thunderbird.

Questions:

1. Was such a mistake detected and corrected in the later versions of
the RC?
2. Is there any reason to consider the report formed by the SEP as
incorrectly formed?
3. Are there any settings in the RC that can fix this error?

--
Best regards,
    Vladimir Gorpenko
_______________________________________________
Roundcube Development discussion mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Fwd: Problem with mixed charsets

Vladimir Gorpenko
I found one error in my letter:
was:     Also, the RC shows that there is an attached file of type xml.
must be: Also, the RC shows that there is an attached file of type html.
---
Best regards,
    Vladimir Gorpenko

-------- Исходное сообщение --------
Тема: [RCD] Problem with mixed charsets
Дата: 2018-07-11 13:03
От: Vladimir Gorpenko <[hidden email]>
Кому: Roundcube Development discussion mailing list
<[hidden email]>
Ответить: Roundcube Development discussion mailing list
<[hidden email]>

Hello!

We are using RC 1.1.4.
I understand that this is an old version, and it is not supported. I ask
you to see my questions at the end of the letter.

A problem was detected with Symantec Endpoint Protection (SEP) reports.

The old version of the SEP generated reports in the form of letters with
an attached file, and the attached file was supplied in a base64 coding.
This worked fine.

The new version forms reports in the form of a multipart letter with
directly included HTML code.
In this case, for the letter as a whole, the charset is not specified.

The first part of the letter has such headings:
Content-Type: text/plain;charset=UTF-8
Content-Transfer-Encoding: base64

The second part of the letter has such headings:
Content-Type: text/html; charset=Cp1251;
        name="=?UTF-8?B?0JXQttC10LTQvdC10LLQvdGL0Lkg0LjRgtC+0LPQvtCy0Ys=?=
  =?UTF-8?B?0Lkg0L7RgtGH0LXRgiDQtNC70Y8g0LDQtNC80LjQvdC4?=
 
=?UTF-8?B?0YHRgtGA0LDRgtC+0YDQsF8xMS4wNy4yMDE4IDctMDAtMjEgNDg3Lmh0bWw=?="
Content-Transfer-Encoding: quoted-printable
Content-Disposition: attachment;
        filename="=?UTF-8?B?0JXQttC10LTQvdC10LLQvdGL0Lkg0LjRgtC+0LPQvtCy0Ys=?=
  =?UTF-8?B?0Lkg0L7RgtGH0LXRgiDQtNC70Y8g0LDQtNC80LjQvdC4?=
 
=?UTF-8?B?0YHRgtGA0LDRgtC+0YDQsF8xMS4wNy4yMDE4IDctMDAtMjEgNDg3Lmh0bWw=?="
Content-ID: 654=52=K9 8B>3>2K9 >BG5B 4;O 04<8=8AB@0B>@0_11.07.2018
7-00-21 487.html

RC correctly displays the body of the letter, that is, the first part.
Also, the RC shows that there is an attached file of type xml.

However, the RC does not correctly save this attached file and, as a
consequence, incorrectly opens it.
First, the size of saved file is about a quarter less than the attached
one.
Secondly, in content, it sharply differs from the same file saved from
the same letter with the help of Thunderbird.

Questions:

1. Was such a mistake detected and corrected in the later versions of
the RC?
2. Is there any reason to consider the report formed by the SEP as
incorrectly formed?
3. Are there any settings in the RC that can fix this error?
_______________________________________________
Roundcube Development discussion mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/dev