RC version 1.4.2 problems with some attached images

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

RC version 1.4.2 problems with some attached images

Jorge
Hi,

Since updating Roundcube from version 1.3.6 to 1.4.2 I have problems with
some emails from GMAIL generated from a mobile phone with an attached image.

When viewing the email, Roundcube does not detect that it has an attachment,
but if I reply or forward that email it does.

I have detected that the problem appears when the attachment has a
"Content-ID:" valued header and is not used as an inline image.

For example, if the attached image is defined like this, Roundcube does not
detect the attachment:
Content-Type: image / jpeg; name = "image1.jpg"
Content-Disposition: attachment; filename = "image1.jpg"
Content-Transfer-Encoding: base64
Content-ID: <f_k6cdcld40>

On the other hand, if it is defined without Content-ID, Roundcube does
detect the attachment and preview the image:
Content-Type: image / jpeg; name = "image1.jpg"
Content-Disposition: attachment; filename = "image1.jpg"
Content-Transfer-Encoding: base64

Has anyone had this problem? Could you solve it?  Is it a program problem or
something that I have configured incorrectly?

Thanks in advance.

Jorge

PS: A simplified version of the raw email to reproduce the problem is as
follows:

MIME-Version: 1.0
From: FROMPERSON <[hidden email]>
Date: Fri, 7 Feb 2020 13:13:25 -0300
Subject: IM4 - with X-Attachment-Id AND with Content-ID
To: "DDESTINATION" <[hidden email]>
Content-Type: multipart/mixed; boundary="000000000000134e5e059dfeac92"
X-PMFLAGS: 570949760 0 5 YZD01IM4.CNM

--000000000000134e5e059dfeac92
Content-Type: multipart/alternative; boundary="000000000000134e5b059dfeac90"

--000000000000134e5b059dfeac90
Content-Type: text/plain; charset="UTF-8"

Text plain content

--000000000000134e5b059dfeac90
Content-Type: text/html; charset="UTF-8"

<div dir="ltr">HTML text content</div>

--000000000000134e5b059dfeac90--
--000000000000134e5e059dfeac92
Content-Type: image/jpeg; name="image1.jpg"
Content-Disposition: attachment; filename="image1.jpg"
Content-Transfer-Encoding: base64
Content-ID: <f_k6cdcld40>

/9j/4AAQSkZJRgABAQEASABIAAD/2wBDAAEBAQEBAQEBAQEBAQEBAQEBAQEBAQEBAQEBAQEBAQEB
AQEBAQICAQECAQEBAgICAgICAgICAQICAgICAgICAgL/2wBDAQEBAQEBAQEBAQECAQEBAgICAgIC
AgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgL/wgARCAAJAAgDASIA
AhEBAxEB/8QAFgABAQEAAAAAAAAAAAAAAAAAAAgJ/8QAFQEBAQAAAAAAAAAAAAAAAAAABwj/2gAM
AwEAAhADEAAAAdHUdGeYv//EABYQAAMAAAAAAAAAAAAAAAAAAAUQF//aAAgBAQABBQKhBl//xAAb
EQAABwEAAAAAAAAAAAAAAAAAAQMGFlOT0f/aAAgBAwEBPwGeOCxLIuj/xAAZEQABBQAAAAAAAAAA
AAAAAAAAAgUWUpL/2gAIAQIBAT8BjLXVez//xAAZEAABBQAAAAAAAAAAAAAAAAAEBRA0k9T/2gAI
AQEABj8CjKdIu1v/xAAUEAEAAAAAAAAAAAAAAAAAAAAQ/9oACAEBAAE/IR9//9oADAMBAAIAAwAA
ABDL/8QAFBEBAAAAAAAAAAAAAAAAAAAAAP/aAAgBAwEBPxBw/8QAFhEAAwAAAAAAAAAAAAAAAAAA
ANHx/9oACAECAQE/EL5H/8QAFBABAAAAAAAAAAAAAAAAAAAAEP/aAAgBAQABPxA9/wD/2Q==
--000000000000134e5e059dfeac92--
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: RC version 1.4.2 problems with some attached images

Fabián Burbano Gutiérrez

There is this bug reported: https://github.com/roundcube/roundcubemail/issues/7122

I suggest you check if it is what you also report or maybe it is different. You can post in that thread, if it's the same or create a new one, if it's something different.

---
Fabián Burbano Gutiérrez
 
 


El 2020-02-07 15:22, Jorge Listas escribió:

Hi,

Since updating Roundcube from version 1.3.6 to 1.4.2 I have problems with
some emails from GMAIL generated from a mobile phone with an attached image.

When viewing the email, Roundcube does not detect that it has an attachment,
but if I reply or forward that email it does.

I have detected that the problem appears when the attachment has a
"Content-ID:" valued header and is not used as an inline image.

For example, if the attached image is defined like this, Roundcube does not
detect the attachment:
Content-Type: image / jpeg; name = "image1.jpg"
Content-Disposition: attachment; filename = "image1.jpg"
Content-Transfer-Encoding: base64
Content-ID: <f_k6cdcld40>

On the other hand, if it is defined without Content-ID, Roundcube does
detect the attachment and preview the image:
Content-Type: image / jpeg; name = "image1.jpg"
Content-Disposition: attachment; filename = "image1.jpg"
Content-Transfer-Encoding: base64

Has anyone had this problem? Could you solve it?  Is it a program problem or
something that I have configured incorrectly?

Thanks in advance.

Jorge

PS: A simplified version of the raw email to reproduce the problem is as
follows:

MIME-Version: 1.0
From: FROMPERSON <[hidden email]>
Date: Fri, 7 Feb 2020 13:13:25 -0300
Subject: IM4 - with X-Attachment-Id AND with Content-ID
To: "DDESTINATION" <[hidden email]>
Content-Type: multipart/mixed; boundary="000000000000134e5e059dfeac92"
X-PMFLAGS: 570949760 0 5 YZD01IM4.CNM

--000000000000134e5e059dfeac92
Content-Type: multipart/alternative; boundary="000000000000134e5b059dfeac90"

--000000000000134e5b059dfeac90
Content-Type: text/plain; charset="UTF-8"

Text plain content

--000000000000134e5b059dfeac90
Content-Type: text/html; charset="UTF-8"

<div dir="ltr">HTML text content</div>

--000000000000134e5b059dfeac90--
--000000000000134e5e059dfeac92
Content-Type: image/jpeg; name="image1.jpg"
Content-Disposition: attachment; filename="image1.jpg"
Content-Transfer-Encoding: base64
Content-ID: <f_k6cdcld40>

/9j/4AAQSkZJRgABAQEASABIAAD/2wBDAAEBAQEBAQEBAQEBAQEBAQEBAQEBAQEBAQEBAQEBAQEB
AQEBAQICAQECAQEBAgICAgICAgICAQICAgICAgICAgL/2wBDAQEBAQEBAQEBAQECAQEBAgICAgIC
AgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgL/wgARCAAJAAgDASIA
AhEBAxEB/8QAFgABAQEAAAAAAAAAAAAAAAAAAAgJ/8QAFQEBAQAAAAAAAAAAAAAAAAAABwj/2gAM
AwEAAhADEAAAAdHUdGeYv//EABYQAAMAAAAAAAAAAAAAAAAAAAUQF//aAAgBAQABBQKhBl//xAAb
EQAABwEAAAAAAAAAAAAAAAAAAQMGFlOT0f/aAAgBAwEBPwGeOCxLIuj/xAAZEQABBQAAAAAAAAAA
AAAAAAAAAgUWUpL/2gAIAQIBAT8BjLXVez//xAAZEAABBQAAAAAAAAAAAAAAAAAEBRA0k9T/2gAI
AQEABj8CjKdIu1v/xAAUEAEAAAAAAAAAAAAAAAAAAAAQ/9oACAEBAAE/IR9//9oADAMBAAIAAwAA
ABDL/8QAFBEBAAAAAAAAAAAAAAAAAAAAAP/aAAgBAwEBPxBw/8QAFhEAAwAAAAAAAAAAAAAAAAAA
ANHx/9oACAECAQE/EL5H/8QAFBABAAAAAAAAAAAAAAAAAAAAEP/aAAgBAQABPxA9/wD/2Q==
--000000000000134e5e059dfeac92--
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users

_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Fwd: Re: RC version 1.4.2 problems with some attached images

Fabián Burbano Gutiérrez


---
Fabián Burbano Gutiérrez
 
 


-------- Mensaje Original --------

Asunto: Re: [RCU] RC version 1.4.2 problems with some attached images
Fecha: 2020-02-09 10:14
De: Fabián Burbano Gutiérrez <[hidden email]>
Destinatario: Jorge Listas <[hidden email]>


Jorge Hola

Efectivamente hablo y escribo bien en español, todo lo contrario en inglés jajajjajaja

Veo que el reporte que hiciste: https://github.com/roundcube/roundcubemail/issues/7214 se cerró y al parecer se soluciona con este: https://github.com/roundcube/roundcubemail/issues/7122 sin embargo todavía no está cerrado. Eso pasó hace 20 horas, así que en la versión que bajaste de git-master todavía no estaba incluida. Este rato se encuentra en pruebas y podrías contribuir a probarlo y comentarlo.

Leo que preguntas si existiría algún problema con algún plugin y la respuesta es tal vez. Solo algunos plugins proporcionan una versión dev-master y en algunos casos solo para pruebas. Todo depende de los plugins que utilices y la suerte que tengas. Debes seguir las instrucciones presentes en el archivo /UPGRADING, sobre todo esto: If you use git sources compile css files for the Elastic skin (required lessc >= 1.5.0)

Para entornos de producción yo sugiero esperar la versión 1.4.3 que saldrá en los próximos días, esperemos que con ese bug resuelto.

Un abrazo Jorge, que bueno alguien que hable español por estos lados.

---
Fabián Burbano Gutiérrez
 
 

Jorge Hi

Indeed I speak and write well in Spanish, quite the opposite happens to me in English jajajjajaja

I see that the report you made: https://github.com/roundcube/roundcubemail/issues/7214 was closed and apparently solved with this: https://github.com/roundcube/roundcubemail/issues/7122 however still it is not closed. That happened 20 hours ago, so in the version you downloaded from git-master it was not yet included. This time is in tests and you could contribute to test and comment.


I saw that you were asking if there would be a problem with any plugin and the answer is maybe. Only some plugins provide a dev-master version and in some cases only for testing. It all depends on the plugins you use and the luck you have. You must follow the instructions in the / UPGRADING file, so you can do all this: If you use git sources compile css files for the Elastic skin (required lessc> = 1.5.0)

For production environments I suggest waiting for version 1.4.3 that will come out in the next few days, hopefully with that bug solved.

A hug Jorge, good someone who speaks Spanish on these sides.

El 2020-02-08 16:40, Jorge Listas escribió:

Hi Fabián,
 
While this inconvenience may be similar to that reported in # 7122 it is somewhat different.

In #7122, I understand, the inconvenience occurs when responding to emails and attaching files.

In my case, the attachments are not shown in the email view either as a preview or as a new window.
Not only that the content of the attachment is not shown, if applicable, but the list of attachments is also not shown.
But, the particular thing is that if I send that email (of which I don't see the list of attachments), I do forward the list with the attachment (which was not visible)
That as it was the version 1.4.2 to 07/01/2020.
 
Entiendo, por tu nombre, que debés hablar español, por lo que te paso la versión en español... ;)
 
Si bien puede ser similar este inconveniente con el reportado en #7122, es algo diferente.
En el #7122, entiendo, el inconveniente se produce al responder emails y adjuntar archivos.
En mi caso, al visualizar un email los adjuntos no se muestran en la vista del mismo ya sea como vista previa o como nueva ventana.

No solo que no se muestra el contenido del adjunto, en el caso de corresponder, sino que tampoco se muestra la lista de adjuntos.

Pero, lo particular del caso es que si a ese email que estoy viendo (del cual no veo la lista de adjuntos) lo reenvío, sí aparece la lista con el adjunto (que no se veía)

Eso tal como estaba la versión 1.4.2 al 07/01/2020.
 
Hoy, luego de una respuesta de Alec (en github) aludiendo a #7117, descargué la versión actualizada (a hoy, 08/02/2020) y no sólo que no se soluciona el problema reportado sino que ahora tampoco se muestra la lista de adjuntos al intentar reenviar el email.
 
Asi es mi situación actual..
 
Saludos
Best regards,
 
Jorge Colaccini
Rosario, Argentina
 
----- Original Message -----
Sent: Friday, February 07, 2020 7:02 PM
Subject: Re: [RCU] RC version 1.4.2 problems with some attached images
 

There is this bug reported: https://github.com/roundcube/roundcubemail/issues/7122

I suggest you check if it is what you also report or maybe it is different. You can post in that thread, if it's the same or create a new one, if it's something different.

---
Fabián Burbano Gutiérrez
 
 


El 2020-02-07 15:22, Jorge Listas escribió:

Hi,

Since updating Roundcube from version 1.3.6 to 1.4.2 I have problems with
some emails from GMAIL generated from a mobile phone with an attached image.

When viewing the email, Roundcube does not detect that it has an attachment,
but if I reply or forward that email it does.

I have detected that the problem appears when the attachment has a
"Content-ID:" valued header and is not used as an inline image.

For example, if the attached image is defined like this, Roundcube does not
detect the attachment:
Content-Type: image / jpeg; name = "image1.jpg"
Content-Disposition: attachment; filename = "image1.jpg"
Content-Transfer-Encoding: base64
Content-ID: <f_k6cdcld40>

On the other hand, if it is defined without Content-ID, Roundcube does
detect the attachment and preview the image:
Content-Type: image / jpeg; name = "image1.jpg"
Content-Disposition: attachment; filename = "image1.jpg"
Content-Transfer-Encoding: base64

Has anyone had this problem? Could you solve it?  Is it a program problem or
something that I have configured incorrectly?

Thanks in advance.

Jorge

PS: A simplified version of the raw email to reproduce the problem is as
follows:

MIME-Version: 1.0
From: FROMPERSON <[hidden email]>
Date: Fri, 7 Feb 2020 13:13:25 -0300
Subject: IM4 - with X-Attachment-Id AND with Content-ID
To: "DDESTINATION" <[hidden email]>
Content-Type: multipart/mixed; boundary="000000000000134e5e059dfeac92"
X-PMFLAGS: 570949760 0 5 YZD01IM4.CNM

--000000000000134e5e059dfeac92
Content-Type: multipart/alternative; boundary="000000000000134e5b059dfeac90"

--000000000000134e5b059dfeac90
Content-Type: text/plain; charset="UTF-8"

Text plain content

--000000000000134e5b059dfeac90
Content-Type: text/html; charset="UTF-8"

<div dir="ltr">HTML text content</div>

--000000000000134e5b059dfeac90--
--000000000000134e5e059dfeac92
Content-Type: image/jpeg; name="image1.jpg"
Content-Disposition: attachment; filename="image1.jpg"
Content-Transfer-Encoding: base64
Content-ID: <f_k6cdcld40>

/9j/4AAQSkZJRgABAQEASABIAAD/2wBDAAEBAQEBAQEBAQEBAQEBAQEBAQEBAQEBAQEBAQEBAQEB
AQEBAQICAQECAQEBAgICAgICAgICAQICAgICAgICAgL/2wBDAQEBAQEBAQEBAQECAQEBAgICAgIC
AgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgL/wgARCAAJAAgDASIA
AhEBAxEB/8QAFgABAQEAAAAAAAAAAAAAAAAAAAgJ/8QAFQEBAQAAAAAAAAAAAAAAAAAABwj/2gAM
AwEAAhADEAAAAdHUdGeYv//EABYQAAMAAAAAAAAAAAAAAAAAAAUQF//aAAgBAQABBQKhBl//xAAb
EQAABwEAAAAAAAAAAAAAAAAAAQMGFlOT0f/aAAgBAwEBPwGeOCxLIuj/xAAZEQABBQAAAAAAAAAA
AAAAAAAAAgUWUpL/2gAIAQIBAT8BjLXVez//xAAZEAABBQAAAAAAAAAAAAAAAAAEBRA0k9T/2gAI
AQEABj8CjKdIu1v/xAAUEAEAAAAAAAAAAAAAAAAAAAAQ/9oACAEBAAE/IR9//9oADAMBAAIAAwAA
ABDL/8QAFBEBAAAAAAAAAAAAAAAAAAAAAP/aAAgBAwEBPxBw/8QAFhEAAwAAAAAAAAAAAAAAAAAA
ANHx/9oACAECAQE/EL5H/8QAFBABAAAAAAAAAAAAAAAAAAAAEP/aAAgBAQABPxA9/wD/2Q==
--000000000000134e5e059dfeac92--
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users

_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: Re: RC version 1.4.2 problems with Contact list

billk

Hello.... I have been using Roundcube Email for +10 years... In editing my contact list for consistency and other information... I assumed it would alphabetize itself when I shut it down... that didn't happen and I can't find what you need to do to get them in alphabetical order... Suggestions appreciated!

Bill Kniegge

 


On 2020-02-09 12:39, Fabián Burbano Gutiérrez wrote:



_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

.... problems with organizing Contact list

billk


Hello.... I have been using Roundcube Email for +10 years... In editing my contact list for consistency and other information... I assumed it would alphabetize itself when I shut it down... that didn't happen and I can't find what you need to do to get them in alphabetical order... Suggestions appreciated!

Bill Kniegge

 


On 2020-02-09 12:39, Fabián Burbano Gutiérrez wrote:



_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users

_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users

Part 2.txt (212 bytes) Download Attachment