RoundCube login problem

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

RoundCube login problem

Daniele Salatti-2
Hi! I'm setting up a mailserver with postfix + dovecot following this HOW-TO (http://workaround.org/articles/ispmail-etch/) and I would like to use RoundCube ( 0.1 rc1) for it. I'm using virtual domains. The problem is that I can't get RoundCube working: every time I try to login i get "Login failed".

I have this in my main.inc.php:

$rcmail_config['virtuser_query'] = "SELECT email FROM mailserver.view_users WHERE email = '%u'";

RoundCube mysql user has reading access to the mailserver DB, and I have successfully tested this query on the DB.
I think the problem is that my imap server is using TLS. Is that "diagnosis" correct? How can I fix it?

Thanks in advance,
Daniele




--
Daniele Salatti
http://www.salatti.net
_______________________________________________
List info: http://lists.roundcube.net/users/
Reply | Threaded
Open this post in threaded view
|

Re: RoundCube login problem

Yusef Maali
Alle 13:08, sabato 6 ottobre 2007, Daniele Salatti ha scritto:
> I think the problem is that my imap server is using TLS. Is that "diagnosis"
> correct? How can I fix it?

I have has the same problem with SquirrelMail and your same configuration (postfix+dovecot).
It started working when I set PLAIN authentication method without TLS.

Maybe, it works also for roundcube.

--
~Yusef
_______________________________________________
List info: http://lists.roundcube.net/users/
Reply | Threaded
Open this post in threaded view
|

Re: RoundCube login problem

Daniele Salatti-2
> I think the problem is that my imap server is using TLS. Is that "diagnosis"
> correct? How can I fix it?

I have has the same problem with SquirrelMail and your same configuration (postfix+dovecot).
It started working when I set PLAIN authentication method without TLS.

Maybe, it works also for roundcube.

Thank you Yusef, but I don't want to disable TLS for security reasons. BTW, I have mynetworks set to 127.0.0.0/8 in /etc/postfix/main.cf, so secure authentication should be disabled for RoundCube...
Any ideas?

Daniele

--
~Yusef
_______________________________________________
List info: http://lists.roundcube.net/users/



--
Daniele Salatti
http://www.salatti.net
_______________________________________________
List info: http://lists.roundcube.net/users/