Still struggeling to get smtp authorization working

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

Still struggeling to get smtp authorization working

Dirk Dettmering Roundcube User Mailinliste
Hello,

I have a working installation of roundcube 1.3.10 and want to upgrade it
to 1.4.X. But from 1.4.0 on I can't get smtp authorization working. Of
course I adjusted the configuration for 1.4.X:

$config['smtp_server'] = 'tls://hostname.domain.tld';
$config['smtp_port'] = 587;
// I also tried $config['smtp_port'] = 465;
$config['smtp_timeout'] = 0;
$config['smtp_user'] = '%u';
$config['smtp_pass'] = '%p';
$config['smtp_auth_type'] = 'PLAIN';
// i also tried $config['smtp_auth_type'] = '';
$config['smtp_debug'] = true;

In thunderbird, seamonkey and K9 on android I can use both port 465 with
SSL/TLS and port 587 with STARTTLS and plain passwords without any
problem to send emails.

The smtp debug log:
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Connecting to
tls://hostname.domain.tld:587...
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 220 hostname.domain.tld
ESMTP Postfix
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Send: EHLO hostname.domain.tld
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250-hostname.domain.tld
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250-PIPELINING
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250-SIZE 50000000
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250-ETRN
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250-STARTTLS
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250-ENHANCEDSTATUSCODES
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250-8BITMIME
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250-DSN
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250-SMTPUTF8
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250 CHUNKING
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Send: STARTTLS
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 220 2.0.0 Ready to start TLS
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Send: EHLO hostname.domain.tld
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250-hostname.domain.tld
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250-PIPELINING
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250-SIZE 50000000
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250-ETRN
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250-ENHANCEDSTATUSCODES
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250-8BITMIME
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250-DSN
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250-SMTPUTF8
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 250 CHUNKING
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Send: QUIT
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> Recv: 221 2.0.0 Bye

The corresponding error log:
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> PHP Error: SMTP server does not
support authentication (POST
/?_task=mail&_unlock=loading1578171182456&_framed=1&_lang=de&_action=send)
[04-Jan-2020 21:53:02 +0100]: <3e1fe9a9> SMTP Error: Authentication
failure: SMTP server does not support authentication (Code: ) in
/usr/local/www/roundcube-1.4.2/program/lib/Roundcube/rcube.php on line
1689 (POST
/?_task=mail&_unlock=loading1578171182456&_framed=1&_lang=de&_action=send)

My system is FreeBSD 12.1 with
Server Version: Apache/2.4.41 (FreeBSD) OpenSSL/1.1.1d-freebsd PHP/7.3.13
In the moment I switch back to RC 1.3.10 by changing a filesystem link
between two directories.

Any help is much appreciated! Thanks in advance

Dirk
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Still struggeling to get smtp authorization working

Benny Pedersen-4
Dirk Dettmering Roundcube User Mailinliste skrev den 2020-01-04 23:45:

> Any help is much appreciated! Thanks in advance

sasl auth is not enabled on this mta, starttls is ok

http://www.postfix.org/SASL_README.html

/etc/postfix/main.cf:
     smtpd_sasl_auth_enable = yes

this example is just not right since it enables sasl auth on port 25

add -o smtpd_sasl_auth_enable=yes into master.cf for submission service
only would work, if you need smtps aswell then enable it aswell in
master.cf

note = must not have space before or after in master.cf

sorry if you are not using postfix, hope its working now
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Still struggeling to get smtp authorization working

Dirk Dettmering Roundcube User Mailinliste
On 05.01.20 00:24, Benny Pedersen wrote:

> Dirk Dettmering Roundcube User Mailinliste skrev den 2020-01-04 23:45:
>
>> Any help is much appreciated! Thanks in advance
>
> sasl auth is not enabled on this mta, starttls is ok
>
> http://www.postfix.org/SASL_README.html
>
> /etc/postfix/main.cf:
>      smtpd_sasl_auth_enable = yes
>
> this example is just not right since it enables sasl auth on port 25
>
> add -o smtpd_sasl_auth_enable=yes into master.cf for submission service
> only would work, if you need smtps aswell then enable it aswell in
> master.cf
>
> note = must not have space before or after in master.cf
>
> sorry if you are not using postfix, hope its working now

Well, I switched to postfix nearly 20 years ago. ;-)

My postfix configuration is roughly as you suggested. SMTP
authentication is working and without a correct username & password
combination nobody can send mails.
Otherwise my server would be an open relay and would be very quickly
blacklisted on several RBLs.

But thanks for your attention - any hint is most welcome

Dirk
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Still struggeling to get smtp authorization working

Dirk Dettmering Roundcube User Mailinliste
On 05.01.20 01:06, Dirk Dettmering Roundcube User Mailinliste wrote:
> My postfix configuration is roughly as you suggested. SMTP
> authentication is working and without a correct username & password
> combination nobody can send mails.
> Otherwise my server would be an open relay and would be very quickly
> blacklisted on several RBLs.
>
> But thanks for your attention - any hint is most welcome

To clarify it: SMTP authentication is working with RC 1.3.10
without any special configuration but not with RC 1.4.X.

Dirk
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Still struggeling to get smtp authorization working

Benny Pedersen-4
Dirk Dettmering Roundcube User Mailinliste skrev den 2020-01-05 01:20:

> To clarify it: SMTP authentication is working with RC 1.3.10
> without any special configuration but not with RC 1.4.X.

i see the ehlo localhost did not expose AUTH

only STARTTLS

i go to bed now :=)

i have rc 1.4.1 working with sasl auth

i know i using rc 1.3.8 here, but that does not change your postfix have
auth disabled on submmisson and smpts

check logs carefully

reboot if nothing helps
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Still struggeling to get smtp authorization working

Mark Constable
In reply to this post by Dirk Dettmering Roundcube User Mailinliste
On 5/1/20 8:45 am, Dirk Dettmering Roundcube User Mailinliste wrote:
> I have a working installation of roundcube 1.3.10 and want to upgrade
> it to 1.4.X. But from 1.4.0 on I can't get smtp authorization
> working. Of course I adjusted the configuration for 1.4.X:

I'm no expert but I just checked my settings and FWIW the only
differences I can see are...

$config['smtp_server'] = 'ssl://hostname.domain.tld';
$config['smtp_port'] = 465;
//$config['smtp_auth_type'] = 'PLAIN'; // default to NULL

> $config['smtp_server'] = 'tls://hostname.domain.tld';
> $config['smtp_port'] = 587;
> // I also tried $config['smtp_port'] = 465;
> $config['smtp_timeout'] = 0;
> $config['smtp_user'] = '%u';
> $config['smtp_pass'] = '%p';
> $config['smtp_auth_type'] = 'PLAIN';

And here, the PHP code should report the fact but the code itself
should not throw a "PHP error" so maybe you have a mismatch of PHP
versions or support libs. Just a wild guess.

"PHP Error: SMTP server does not support authentication"

--
Mark Constable
0419 530 037
https://spiderweb.com.au
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Still struggeling to get smtp authorization working

@lbutlr
In reply to this post by Dirk Dettmering Roundcube User Mailinliste
On 04 Jan 2020, at 15:45, Dirk Dettmering Roundcube User Mailinliste <[hidden email]> wrote:
> $config['smtp_server'] = 'tls://hostname.domain.tld';
> $config['smtp_port'] = 587;
> // I also tried $config['smtp_port'] = 465;
> $config['smtp_timeout'] = 0;
> $config['smtp_user'] = '%u';
> $config['smtp_pass'] = '%p';
> $config['smtp_auth_type'] = 'PLAIN';
> // i also tried $config['smtp_auth_type'] = '';
> $config['smtp_debug'] = true;

This is what I have, which other than the port is basically identical:

$config['smtp_server'] = 'tls://mail.covisp.net/';
$config['smtp_port'] = 587;
$config['smtp_user'] = '%u';
$config['smtp_pass'] = '%p’;
$config['imap_auth_type'] = 'PLAIN’;

I do not have a timeout set for SMTP, so first suggestion is comment that out.

For postfix (3.4.8):

In master.cf I have:
submission inet  n       -       n       -       -       smtpd
    -o smtpd_tls_security_level=encrypt
    -o smtpd_sasl_auth_enable=yes
    -o smtpd_sasl_type=dovecot
    -o smtpd_sasl_security_options=noanonymous
    -o smtpd_sasl_path=private/auth
    -o smtpd_milters=
    -o milter_connect_macros=
    -o milter_macro_daemon_name=ORIGINATING
    -o syslog_name=postfix/submit
    -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    -o smtpd_data_restrictions=
    -o smtpd_relay_restrictions=permit_sasl_authenticated,reject
    -o smtpd_helo_restrictions=
    -o smtpd_recipient_restrictions=permit_sasl_authenticated,reject

In main.cf:
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_sasl_path = private/auth
smtpd_sasl_type = dovecot

You posted logs from roundcube, but what does postfix log at the same time?

RC 1.4.x worked drop=in update over 1.3.x with no issues.


_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Still struggeling to get smtp authorization working

Remo Mattei
Are you running Ubuntu or CentOS?
Do you have selinux enabled?

> Il giorno 5 gen 2020, alle ore 10:38, @lbutlr <[hidden email]> ha scritto:
>
> On 04 Jan 2020, at 15:45, Dirk Dettmering Roundcube User Mailinliste <[hidden email]> wrote:
>> $config['smtp_server'] = 'tls://hostname.domain.tld';
>> $config['smtp_port'] = 587;
>> // I also tried $config['smtp_port'] = 465;
>> $config['smtp_timeout'] = 0;
>> $config['smtp_user'] = '%u';
>> $config['smtp_pass'] = '%p';
>> $config['smtp_auth_type'] = 'PLAIN';
>> // i also tried $config['smtp_auth_type'] = '';
>> $config['smtp_debug'] = true;
>
> This is what I have, which other than the port is basically identical:
>
> $config['smtp_server'] = 'tls://mail.covisp.net/';
> $config['smtp_port'] = 587;
> $config['smtp_user'] = '%u';
> $config['smtp_pass'] = '%p’;
> $config['imap_auth_type'] = 'PLAIN’;
>
> I do not have a timeout set for SMTP, so first suggestion is comment that out.
>
> For postfix (3.4.8):
>
> In master.cf I have:
> submission inet  n       -       n       -       -       smtpd
>    -o smtpd_tls_security_level=encrypt
>    -o smtpd_sasl_auth_enable=yes
>    -o smtpd_sasl_type=dovecot
>    -o smtpd_sasl_security_options=noanonymous
>    -o smtpd_sasl_path=private/auth
>    -o smtpd_milters=
>    -o milter_connect_macros=
>    -o milter_macro_daemon_name=ORIGINATING
>    -o syslog_name=postfix/submit
>    -o smtpd_client_restrictions=permit_sasl_authenticated,reject
>    -o smtpd_data_restrictions=
>    -o smtpd_relay_restrictions=permit_sasl_authenticated,reject
>    -o smtpd_helo_restrictions=
>    -o smtpd_recipient_restrictions=permit_sasl_authenticated,reject
>
> In main.cf:
> broken_sasl_auth_clients = yes
> smtpd_sasl_authenticated_header = yes
> smtpd_sasl_path = private/auth
> smtpd_sasl_type = dovecot
>
> You posted logs from roundcube, but what does postfix log at the same time?
>
> RC 1.4.x worked drop=in update over 1.3.x with no issues.
>
>
> _______________________________________________
> Roundcube Users mailing list
> [hidden email]
> http://lists.roundcube.net/mailman/listinfo/users
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Still struggeling to get smtp authorization working

Dirk Dettmering Roundcube User Mailinliste
In reply to this post by @lbutlr
Thanks for your and the other suggestions. I will try them in the next
days. As the server is productive I can change essential settings only
outside working hours in a small time slot.
I'm just wondering why my other mail clients can send mail with SMTP
authentication and RC doesn't? But maybe RC needs mandatory the SMTP
AUTH banner in the smtp dialogue?

Bye

Dirk


On 05.01.20 19:37, @lbutlr wrote:

> On 04 Jan 2020, at 15:45, Dirk Dettmering Roundcube User Mailinliste <[hidden email]> wrote:
>> $config['smtp_server'] = 'tls://hostname.domain.tld';
>> $config['smtp_port'] = 587;
>> // I also tried $config['smtp_port'] = 465;
>> $config['smtp_timeout'] = 0;
>> $config['smtp_user'] = '%u';
>> $config['smtp_pass'] = '%p';
>> $config['smtp_auth_type'] = 'PLAIN';
>> // i also tried $config['smtp_auth_type'] = '';
>> $config['smtp_debug'] = true;
>
> This is what I have, which other than the port is basically identical:
>
> $config['smtp_server'] = 'tls://mail.covisp.net/';
> $config['smtp_port'] = 587;
> $config['smtp_user'] = '%u';
> $config['smtp_pass'] = '%p’;
> $config['imap_auth_type'] = 'PLAIN’;
>
> I do not have a timeout set for SMTP, so first suggestion is comment that out.
>
> For postfix (3.4.8):
>
> In master.cf I have:
> submission inet  n       -       n       -       -       smtpd
>      -o smtpd_tls_security_level=encrypt
>      -o smtpd_sasl_auth_enable=yes
>      -o smtpd_sasl_type=dovecot
>      -o smtpd_sasl_security_options=noanonymous
>      -o smtpd_sasl_path=private/auth
>      -o smtpd_milters=
>      -o milter_connect_macros=
>      -o milter_macro_daemon_name=ORIGINATING
>      -o syslog_name=postfix/submit
>      -o smtpd_client_restrictions=permit_sasl_authenticated,reject
>      -o smtpd_data_restrictions=
>      -o smtpd_relay_restrictions=permit_sasl_authenticated,reject
>      -o smtpd_helo_restrictions=
>      -o smtpd_recipient_restrictions=permit_sasl_authenticated,reject
>
> In main.cf:
> broken_sasl_auth_clients = yes
> smtpd_sasl_authenticated_header = yes
> smtpd_sasl_path = private/auth
> smtpd_sasl_type = dovecot
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Still struggeling to get smtp authorization working

@lbutlr
On 05 Jan 2020, at 14:55, Dirk Dettmering Roundcube User Mailinliste <[hidden email]> wrote:
> Thanks for your and the other suggestions. I will try them in the next days. As the server is productive I can change essential settings only outside working hours in a small time slot.

Create a link under your www root and test away. (I had /www/usr/local/www/RC4-test-65afe8c2 for about a week before I moved it over to be the live webmail.

> I'm just wondering why my other mail clients can send mail with SMTP authentication and RC doesn't? But maybe RC needs mandatory the SMTP AUTH banner in the smtp dialogue?

Nope, there is no SMTP AUTH on my port 587, just STARTTLS

250-mail.covisp.net
250-PIPELINING
250-SIZE 26214400
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250-DSN
250 CHUNKING

On port 465 there is, but I do not use that for Roundcube (no reason, just I only recently added support on my server for port 465).

250-mail.covisp.net
250-PIPELINING
250-SIZE 26214400
250-ETRN
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250-DSN
250 CHUNKING



--
Competent? How are we going to compete with that?
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Still struggeling to get smtp authorization working

Nuno Dias
In reply to this post by Dirk Dettmering Roundcube User Mailinliste
 Hi,

 I had the same problem after upgrading, you need to add this to your
configuration and the error about your server "does not
support authentication" is  misleading

$config['smtp_conn_options'] = array(
   'ssl'         => array(
     'verify_peer'  => true,
     'verify_depth' => 3,
     'cafile'       => '/etc/pki/tls/certs/cafile.crt',
   ),
 );

Cheers,
Nuno

On Sun, 2020-01-05 at 22:55 +0100, Dirk Dettmering Roundcube User
Mailinliste wrote:

> Thanks for your and the other suggestions. I will try them in the
> next
> days. As the server is productive I can change essential settings
> only
> outside working hours in a small time slot.
> I'm just wondering why my other mail clients can send mail with SMTP
> authentication and RC doesn't? But maybe RC needs mandatory the SMTP
> AUTH banner in the smtp dialogue?
>
> Bye
>
> Dirk
>
>
> On 05.01.20 19:37, @lbutlr wrote:
> > On 04 Jan 2020, at 15:45, Dirk Dettmering Roundcube User
> > Mailinliste <[hidden email]> wrote:
> > > $config['smtp_server'] = 'tls://hostname.domain.tld';
> > > $config['smtp_port'] = 587;
> > > // I also tried $config['smtp_port'] = 465;
> > > $config['smtp_timeout'] = 0;
> > > $config['smtp_user'] = '%u';
> > > $config['smtp_pass'] = '%p';
> > > $config['smtp_auth_type'] = 'PLAIN';
> > > // i also tried $config['smtp_auth_type'] = '';
> > > $config['smtp_debug'] = true;
> >
> > This is what I have, which other than the port is basically
> > identical:
> >
> > $config['smtp_server'] = 'tls://mail.covisp.net/';
> > $config['smtp_port'] = 587;
> > $config['smtp_user'] = '%u';
> > $config['smtp_pass'] = '%p’;
> > $config['imap_auth_type'] = 'PLAIN’;
> >
> > I do not have a timeout set for SMTP, so first suggestion is
> > comment that out.
> >
> > For postfix (3.4.8):
> >
> > In master.cf I have:
> > submission inet  n       -       n       -       -       smtpd
> >      -o smtpd_tls_security_level=encrypt
> >      -o smtpd_sasl_auth_enable=yes
> >      -o smtpd_sasl_type=dovecot
> >      -o smtpd_sasl_security_options=noanonymous
> >      -o smtpd_sasl_path=private/auth
> >      -o smtpd_milters=
> >      -o milter_connect_macros=
> >      -o milter_macro_daemon_name=ORIGINATING
> >      -o syslog_name=postfix/submit
> >      -o smtpd_client_restrictions=permit_sasl_authenticated,reject
> >      -o smtpd_data_restrictions=
> >      -o smtpd_relay_restrictions=permit_sasl_authenticated,reject
> >      -o smtpd_helo_restrictions=
> >      -o
> > smtpd_recipient_restrictions=permit_sasl_authenticated,reject
> >
> > In main.cf:
> > broken_sasl_auth_clients = yes
> > smtpd_sasl_authenticated_header = yes
> > smtpd_sasl_path = private/auth
> > smtpd_sasl_type = dovecot
> _______________________________________________
> Roundcube Users mailing list
> [hidden email]
> http://lists.roundcube.net/mailman/listinfo/users
--
Nuno Dias <[hidden email]>
LIP

_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users

smime.p7s (3K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Still struggeling to get smtp authorization working

@lbutlr
On 06 Jan 2020, at 07:12, Nuno Dias <[hidden email]> wrote:
> $config['smtp_conn_options'] = array(
>   'ssl'         => array(
>     'verify_peer'  => true,
>     'verify_depth' => 3,
>     'cafile'       => '/etc/pki/tls/certs/cafile.crt',
>   ),
> );

I have:

$config['imap_conn_options'] = array(
  'ssl' => array(
     'verify_peer'  => false,
     'verify_depth' => 0,
   ),
);

Since my attempts to get RC1.3 (or maybe 1.2?) to work with my LE certs  failed entirely.




--
"He has never been known to use a word that might send a reader to
        the dictionary." - William Faulkner (about Ernest Hemingway).
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Still struggeling to get smtp authorization working

Nuno Dias
 In my tests If "verify_peer'  => false," the authentication always
fails, the configuration I sent was the solution to get the new version
working.

Cheers,
Nuno

On Mon, 2020-01-06 at 18:25 -0700, @lbutlr wrote:

> On 06 Jan 2020, at 07:12, Nuno Dias <[hidden email]> wrote:
> > $config['smtp_conn_options'] = array(
> >   'ssl'         => array(
> >     'verify_peer'  => true,
> >     'verify_depth' => 3,
> >     'cafile'       => '/etc/pki/tls/certs/cafile.crt',
> >   ),
> > );
>
> I have:
>
> $config['imap_conn_options'] = array(
>   'ssl' => array(
>      'verify_peer'  => false,
>      'verify_depth' => 0,
>    ),
> );
>
> Since my attempts to get RC1.3 (or maybe 1.2?) to work with my LE
> certs  failed entirely.
>
>
>
>
--
Nuno Dias <[hidden email]>
LIP

_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users

smime.p7s (3K) Download Attachment