another PGP thingi

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

another PGP thingi

Andreas Meyer
Hello!

I run two domains on one host. With one I have no problem using PGP with
the otherone it does not work.
Both domains use version 1.3.3 and enigma 0.7.

Importing keys works, signing and encryption does not.
I set $config['debug_level'] = 4; but nothing is logged at the moment.

How can I debug that thing? I get the pinentry thing to input the
passphrase
and then it says signing failed.

Regards

   Andreas

--
PGP-Fingerprint: D392 5D21 0299 63D7 5BAE 4562 1E56 B2EA 81A2 59F1
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: another PGP thingi

Andreas Meyer
Am 2018-03-01 21:01, schrieb Andreas Meyer:

> Hello!
>
> I run two domains on one host. With one I have no problem using PGP
> with the otherone it does not work.
> Both domains use version 1.3.3 and enigma 0.7.
>
> Importing keys works, signing and encryption does not.
> I set $config['debug_level'] = 4; but nothing is logged at the moment.
>
> How can I debug that thing? I get the pinentry thing to input the
> passphrase
> and then it says signing failed.

After disabling $config['debug_level'] = 4 I see this in the log:

[01-Mar-2018 21:00:50 +0100]: <upfgboj6> PHP Error: Enigma plugin:
Unknown error detach-signing data. Please use the 'debug' option when
creating the Crypt_GPG object, and file a bug report at
http://pear.php.net/bugs/report.php?package=Crypt_GPG in
/vwww/HIDDEN/root/mailsystem/plugins/enigma/lib/enigma_engine.php on
line 914 (POST
/mailsystem/?_task=mail&_unlock=loading1519934450236&_lang=de_DE&_framed=1&_action=send)

Kind regards

   Andreas

--
PGP-Fingerprint: D392 5D21 0299 63D7 5BAE 4562 1E56 B2EA 81A2 59F1
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: another PGP thingi

Andreas Meyer
Am 2018-03-01 21:10, schrieb Andreas Meyer:

>> How can I debug that thing? I get the pinentry thing to input the
>> passphrase
>> and then it says signing failed.
>
> After disabling $config['debug_level'] = 4 I see this in the log:
>
> [01-Mar-2018 21:00:50 +0100]: <upfgboj6> PHP Error: Enigma plugin:
> Unknown error detach-signing data. Please use the 'debug' option when
> creating the Crypt_GPG object, and file a bug report at
> http://pear.php.net/bugs/report.php?package=Crypt_GPG in
> /vwww/HIDDEN/root/mailsystem/plugins/enigma/lib/enigma_engine.php on
> line 914 (POST
> /mailsystem/?_task=mail&_unlock=loading1519934450236&_lang=de_DE&_framed=1&_action=send)
Seems it was a problem with permissions. After a chown -R wwwrun:www .
in enigma/home/>account> signing and encryption works. Not shure if this
is ok.

Greetings

   Andreas

--
PGP-Fingerprint: D392 5D21 0299 63D7 5BAE 4562 1E56 B2EA 81A2 59F1


_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users

signature.asc (220 bytes) Download Attachment