can't login after upgrade

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

can't login after upgrade

Meaulnes Legler @ roundcube

hello again

I'm still having login problems on different sites on my webserver. On several sites, I upgraded from version 1.2.4 to 1.3.7 and since then, a login attempt says « /!\ Login failed ». Users at sites running RoundCube 1.2.4 have no problems.

A.L.E.C. said, I should fix the database. How can I do this? I couldn't find any instructions online...

Thank you and best regards
_~_
'¿')
`-´
 Meaulnes Legler
 Zurich, Switzerland
+41\0 44 260 16 60


_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: can't login after upgrade

Mike Burger
Have you run the <RCEMAILDIR>/bin/updatedb.sh script, yet?

On 2018-10-05 10:17, Meaulnes Legler @ roundcube wrote:

> hello again
>
> I'm still having login problems on different sites on my webserver. On
> several sites, I upgraded from version 1.2.4 to 1.3.7 and since then,
> a login attempt says « /!\ Login failed ». Users at sites running
> RoundCube 1.2.4 have no problems.
>
> A.L.E.C. said, I should fix the database. How can I do this? I
> couldn't find any instructions online...
>  Thank you and best regards

--
Mike Burger
http://www.bubbanfriends.org

"It's always suicide-mission this, save-the-planet that. No one ever
just stops by to say 'hi' anymore." --Colonel Jack O'Neill, SG1
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: can't login after upgrade

Meaulnes Legler @ roundcube

hey Mike, thanks for the reply!

On 05.10.18 17:19, Mike Burger wrote:
Have you run the <RCEMAILDIR>/bin/updatedb.sh script, yet?

no, I didn't, but I tried now and it says:

483# bin/updatedb.sh
Error 500: Database schema directory not specified (--dir).
484#

what params do I have to enter?

Thank you and best regards

Meaulnes Legler
Zurich, Switzerland



On 2018-10-05 10:17, Meaulnes Legler @ roundcube wrote:
hello again

I'm still having login problems on different sites on my webserver. On
several sites, I upgraded from version 1.2.4 to 1.3.7 and since then,
a login attempt says « /!\ Login failed ». Users at sites running
RoundCube 1.2.4 have no problems.

A.L.E.C. said, I should fix the database. How can I do this? I
couldn't find any instructions online...
 Thank you and best regards


--
Meaulnes Legler ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ http://www.WaveWeb.ch ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ Zurich, Switzerland ~ ~ +41\0 44 260 16 60 ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~

Meaulnes Legler
~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~
 www.WaveWeb.ch  ~
~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~
Zurich, Switzerland ~
tel: +41 44 2601660 ~


_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: can't login after upgrade

Meaulnes Legler @ roundcube
In reply to this post by Mike Burger

hey Mike, thanks for the reply!

On 05.10.18 17:19, Mike Burger wrote:
Have you run the <RCEMAILDIR>/bin/updatedb.sh script, yet?

no, I didn't, but I tried now and it says:

483# bin/updatedb.sh
Error 500: Database schema directory not specified (--dir).
484#

what params do I have to enter?

2nd question: how can I get more specific error messages as just a lapidary « /!\ Login failed » ?

Thank you and best regards

Meaulnes Legler
Zurich, Switzerland



On 2018-10-05 10:17, Meaulnes Legler @ roundcube wrote:
hello again

I'm still having login problems on different sites on my webserver. On
several sites, I upgraded from version 1.2.4 to 1.3.7 and since then,
a login attempt says « /!\ Login failed ». Users at sites running
RoundCube 1.2.4 have no problems.

A.L.E.C. said, I should fix the database. How can I do this? I
couldn't find any instructions online...
 Thank you and best regards


--
Meaulnes Legler ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ http://www.WaveWeb.ch ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ Zurich, Switzerland ~ ~ +41\0 44 260 16 60 ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~

Meaulnes Legler
~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~
 www.WaveWeb.ch  ~
~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~
Zurich, Switzerland ~
tel: +41 44 2601660 ~


_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: can't login after upgrade

Meaulnes Legler @ roundcube
In reply to this post by Mike Burger

dear RoundCubers

it's me again, I still cannot login after an update to version 1.3.7...

After googling the necessary bin/updatedb.sh params, I got:
497# bin/update.sh --package roundcube --dir=./SQL
What version are you upgrading from? Type '?' if you don't know.
?
WARNING: Mimetype to file extension mapping doesn't work properly!
Please check the 'mime_types' config option and run this script again.
Executing database schema update.
Updating database schema (2013011000)... [OK]
Updating database schema (2013042700)... [OK]
Updating database schema (2013052500)... [OK]
Updating database schema (2013061000)... [OK]
Updating database schema (2014042900)... [OK]
Updating database schema (2015030800)... [OK]
Updating database schema (2015111100)... [OK]
Updating database schema (2016081200)... [OK]
Updating database schema (2016100900)... [OK]
Updating database schema (2016112200)... [OK]
This instance of Roundcube is up-to-date.
Have fun!
498#

I was all exited thinking it would work now, but it I didn't :-( Still get the « /!\ Login failed » error with the correct credentials.

I uninstalled and reinstalled RC and went thru the same procedures — no success.

2nd question: how can I get more specific error messages as just a lapidary « /!\ Login failed » ?

Thank you and best regards

Meaulnes Legler
Zurich, Switzerland



_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: can't login after upgrade

Vincent Van Houtte
To your second question, you may want to look into Roundcube logging,
f.e.

$config['per_user_logging'] = true;
$config['log_session'] = true;
$config['log_logins'] = true;
$config['debug_level'] = 4;
$config['sql_debug'] = true;
$config['imap_debug'] = true;
$config['imap_log_session'] = true;
$config['ldap_debug'] = true;
$config['smtp_log'] = true;
$config['smtp_debug'] = true;

This may help you retrieve more specific error codes

Kr,
Vincent

On 2018-10-08 14:06, Meaulnes Legler @ roundcube wrote:

> dear RoundCubers
>
> it's me again, I still cannot login after an update to version 1.3.7...
> After googling the necessary bin/updatedb.sh params, I got:
>
> 497# bin/update.sh --package roundcube --dir=./SQL
> What version are you upgrading from? Type '?' if you don't know.
> ?
> WARNING: Mimetype to file extension mapping doesn't work properly!
> Please check the 'mime_types' config option and run this script again.
> Executing database schema update.
> Updating database schema (2013011000)... [OK]
> Updating database schema (2013042700)... [OK]
> Updating database schema (2013052500)... [OK]
> Updating database schema (2013061000)... [OK]
> Updating database schema (2014042900)... [OK]
> Updating database schema (2015030800)... [OK]
> Updating database schema (2015111100)... [OK]
> Updating database schema (2016081200)... [OK]
> Updating database schema (2016100900)... [OK]
> Updating database schema (2016112200)... [OK]
> This instance of Roundcube is up-to-date.
> Have fun!
> 498#
>
> I was all exited thinking it would work now, but it I didn't :-( Still
> get the « /!\ Login failed » error with the correct credentials.
>
> I uninstalled and reinstalled RC and went thru the same procedures --
> no success.
>
> 2nd question: how can I get more specific error messages as just a
> lapidary « /!\ Login failed » ?
>
> Thank you and best regards
>
> Meaulnes Legler
> Zurich, Switzerland
>
> _______________________________________________
> Roundcube Users mailing list
> [hidden email]
> http://lists.roundcube.net/mailman/listinfo/users


Vincent Van Houtte
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: can't login after upgrade

Benny Pedersen-4
In reply to this post by Meaulnes Legler @ roundcube
Meaulnes Legler @ roundcube skrev den 2018-10-08 14:06:

> 497# bin/update.sh --package roundcube --dir=./SQL
> What version are you upgrading from? Type '?' if you don't know.

try running bin/update.sh

eq no args

check config.inc.php, is this configured like it was in last version
before update install ?

and i think you miss some needed updates in php deependice that are
missed by the maintainers on your os
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: can't login after upgrade

Meaulnes Legler @ roundcube
In reply to this post by Meaulnes Legler @ roundcube
On 08.10.18 14:37, Reindl Harald wrote:
Am 08.10.18 um 14:06 schrieb Meaulnes Legler@roundcube:
_2nd question:_ how can I get more specific error messages as just a
lapidary « _/!\_ Login failed » ?
have you ever considered to look at your maillog?
roundcube is just a client

yes I did, it just says logged in and logged out.

502# less /var/log/maillog | grep username
Oct  8 14:32:12 blue2 dovecot: imap-login: Login: user=, method=PLAIN, rip=94.103.xx.xx, lip=94.103.xx.xx, mpid=32040, secured, session=
Oct  8 14:32:12 blue2 dovecot: imap(username): Logged out in=29 out=496
503#

so I guess the login was correct but the session obviously doesn't last...

when you see no conenction your config is wrong, when you see
connections you see also what fails

yeah well no clue why the session doesn't stay alive.

Thank you and best regards

_~_
'¿')
`-´
 Meaulnes Legler
 Zurich, Switzerland
+41\0 44 260 16 60


_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: can't login after upgrade

Meaulnes Legler @ roundcube
In reply to this post by Vincent Van Houtte

thanks Vincent for your answer

On 08.10.18 14:37, Vincent Van Houtte wrote:
To your second question, you may want to look into Roundcube logging, f.e.

I got the following, but it doesn't help me on...

506# tail roundcube/logs/errors
...
[08-Oct-2018 14:32:12 +0200]: <345va73k> PHP Error: Failed to create new user in /home/.sites/106/site3/web/roundcube/program/lib/Roundcube/rcube_user.php on line 688 (POST /roundcube/?_task=login&_action=login)
[08-Oct-2018 14:32:12 +0200]: <345va73k> PHP Error: Failed to create a user record. Maybe aborted by a plugin? in /home/.sites/106/site3/web/roundcube/program/include/rcmail.php on line 652 (POST /roundcube/?_task=login&_action=login)
[08-Oct-2018 15:37:11 +0200]: <345va73k> DB Error: [1364] Field 'alias' doesn't have a default value (SQL Query: INSERT INTO `users` (`created`, `last_login`, `username`, `mail_host`, `language`) VALUES (now(), now(), 'arcgraph', 'www.arcgraphics.ch', 'en_US')) in /home/.sites/106/site3/web/roundcube/program/lib/Roundcube/rcube_db.php on line 543 (POST /roundcube/?_task=login&_action=login)[08-Oct-2018 15:37:11 +0200]: <345va73k> PHP Error: Failed to create new user in /home/.sites/106/site3/web/roundcube/program/lib/Roundcube/rcube_user.php on line 688 (POST /roundcube/?_task=login&_action=login)
[08-Oct-2018 15:37:11 +0200]: <345va73k> PHP Error: Failed to create a user record. Maybe aborted by a plugin? in /home/.sites/106/site3/web/roundcube/program/include/rcmail.php on line 652 (POST /roundcube/?_task=login&_action=login)
logs/errors lines 1-18/18 (END)
507#

I don't know why this 'alias' field shows up here, I uninstalled and reinstalled RG, the database seems okay after bin/updatedb.sh --package roundcube --dir=./SQL and after bin/update.sh --package roundcube --dir=./SQL, it wished me Have fun! :-(

Any clue?

Thank you and best regards

_~_
'¿')
`-´
 Meaulnes Legler
 Zurich, Switzerland
+41\0 44 260 16 60


$config['per_user_logging'] = true;
$config['log_session'] = true;
$config['log_logins'] = true;
$config['debug_level'] = 4;
$config['sql_debug'] = true;
$config['imap_debug'] = true;
$config['imap_log_session'] = true;
$config['ldap_debug'] = true;
$config['smtp_log'] = true;
$config['smtp_debug'] = true;

This may help you retrieve more specific error codes

Kr,
Vincent

On 2018-10-08 14:06, Meaulnes Legler @ roundcube wrote:

dear RoundCubers

it's me again, I still cannot login after an update to version 1.3.7... After googling the necessary bin/updatedb.sh params, I got:

497# bin/update.sh --package roundcube --dir=./SQL
What version are you upgrading from? Type '?' if you don't know.
?
WARNING: Mimetype to file extension mapping doesn't work properly!
Please check the 'mime_types' config option and run this script again.
Executing database schema update.
Updating database schema (2013011000)... [OK]
Updating database schema (2013042700)... [OK]
Updating database schema (2013052500)... [OK]
Updating database schema (2013061000)... [OK]
Updating database schema (2014042900)... [OK]
Updating database schema (2015030800)... [OK]
Updating database schema (2015111100)... [OK]
Updating database schema (2016081200)... [OK]
Updating database schema (2016100900)... [OK]
Updating database schema (2016112200)... [OK]
This instance of Roundcube is up-to-date.
Have fun!
498#

I was all exited thinking it would work now, but it I didn't :-( Still get the « /!\ Login failed » error with the correct credentials.

I uninstalled and reinstalled RC and went thru the same procedures -- no success.

2nd question: how can I get more specific error messages as just a lapidary « /!\ Login failed » ?

Thank you and best regards

Meaulnes Legler
Zurich, Switzerland

_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users


Vincent Van Houtte



_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: can't login after upgrade

Remo Mattei
In reply to this post by Benny Pedersen-4
I think you need to set the option AUTH lo login or plain.

> Il giorno 8 ott 2018, alle ore 06:01, Benny Pedersen <[hidden email]> ha scritto:
>
> Meaulnes Legler @ roundcube skrev den 2018-10-08 14:06:
>
>> 497# bin/update.sh --package roundcube --dir=./SQL
>> What version are you upgrading from? Type '?' if you don't know.
>
> try running bin/update.sh
>
> eq no args
>
> check config.inc.php, is this configured like it was in last version before update install ?
>
> and i think you miss some needed updates in php deependice that are missed by the maintainers on your os
> _______________________________________________
> Roundcube Users mailing list
> [hidden email]
> http://lists.roundcube.net/mailman/listinfo/users
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: can't login after upgrade

Vincent Van Houtte
In reply to this post by Meaulnes Legler @ roundcube
On 2018-10-08 16:01, Meaulnes Legler @ roundcube wrote:

> thanks Vincent for your answer
>
> On 08.10.18 14:37, Vincent Van Houtte wrote:
>
>> To your second question, you may want to look into Roundcube logging,
>> f.e.
>
> I got the following, but it doesn't help me on...
>
> 506# tail roundcube/logs/errors
> ...
> [08-Oct-2018 14:32:12 +0200]: <345va73k> PHP Error: Failed to create
> new user in
> /home/.sites/106/site3/web/roundcube/program/lib/Roundcube/rcube_user.php
> on line 688 (POST /roundcube/?_task=login&_action=login)
> [08-Oct-2018 14:32:12 +0200]: <345va73k> PHP Error: Failed to create a
> user record. Maybe aborted by a plugin? in
> /home/.sites/106/site3/web/roundcube/program/include/rcmail.php on line
> 652 (POST /roundcube/?_task=login&_action=login)
> [08-Oct-2018 15:37:11 +0200]: <345va73k> DB Error: [1364] Field 'alias'
> doesn't have a default value (SQL Query: INSERT INTO `users`
> (`created`, `last_login`, `username`, `mail_host`, `language`) VALUES
> (now(), now(), 'arcgraph', 'www.arcgraphics.ch', 'en_US')) in
> /home/.sites/106/site3/web/roundcube/program/lib/Roundcube/rcube_db.php
> on line 543 (POST /roundcube/?_task=login&_action=login)[08-Oct-2018
> 15:37:11 +0200]: <345va73k> PHP Error: Failed to create new user in
> /home/.sites/106/site3/web/roundcube/program/lib/Roundcube/rcube_user.php
> on line 688 (POST /roundcube/?_task=login&_action=login)
> [08-Oct-2018 15:37:11 +0200]: <345va73k> PHP Error: Failed to create a
> user record. Maybe aborted by a plugin? in
> /home/.sites/106/site3/web/roundcube/program/include/rcmail.php on line
> 652 (POST /roundcube/?_task=login&_action=login)
> logs/errors lines 1-18/18 (END)
> 507#
>
> I don't know why this 'alias' field shows up here, I uninstalled and
> reinstalled RG, the database seems okay after bin/updatedb.sh --package
> roundcube --dir=./SQL and after bin/update.sh --package roundcube
> --dir=./SQL, it wished me Have fun! :-(
>
> Any clue?

These errors clearly say that the user 'arcgraph' does not exist, that
RC wants to create the user by logging in (I don't believe this is
default - an unknown user should just be rejected imho), and that the
subsequent attempt to create that user fails.

There is also the mention of a plugin that may interfere here. Can you
disable all plugins for the sake of testing?

HTH,
Vincent



> Thank you and best regards
>
> _~_
> '¿')
> `-´          Meaulnes Legler
>
> Zurich, Switzerland
>
> +41\0 44 260 16 60
>
> $config['per_user_logging'] = true;
> $config['log_session'] = true;
> $config['log_logins'] = true;
> $config['debug_level'] = 4;
> $config['sql_debug'] = true;
> $config['imap_debug'] = true;
> $config['imap_log_session'] = true;
> $config['ldap_debug'] = true;
> $config['smtp_log'] = true;
> $config['smtp_debug'] = true;
>
> This may help you retrieve more specific error codes
>
> Kr,
> Vincent
>
> On 2018-10-08 14:06, Meaulnes Legler @ roundcube wrote:
>
> dear RoundCubers
>
> it's me again, I still cannot login after an update to version 1.3.7...
> After googling the necessary bin/updatedb.sh params, I got:
>
> 497# bin/update.sh --package roundcube --dir=./SQL
> What version are you upgrading from? Type '?' if you don't know.
> ?
> WARNING: Mimetype to file extension mapping doesn't work properly!
> Please check the 'mime_types' config option and run this script again.
> Executing database schema update.
> Updating database schema (2013011000)... [OK]
> Updating database schema (2013042700)... [OK]
> Updating database schema (2013052500)... [OK]
> Updating database schema (2013061000)... [OK]
> Updating database schema (2014042900)... [OK]
> Updating database schema (2015030800)... [OK]
> Updating database schema (2015111100)... [OK]
> Updating database schema (2016081200)... [OK]
> Updating database schema (2016100900)... [OK]
> Updating database schema (2016112200)... [OK]
> This instance of Roundcube is up-to-date.
> Have fun!
> 498#
>
> I was all exited thinking it would work now, but it I didn't :-( Still
> get the « /!\ Login failed » error with the correct credentials.
>
> I uninstalled and reinstalled RC and went thru the same procedures --
> no success.
>
> 2nd question: how can I get more specific error messages as just a
> lapidary « /!\ Login failed » ?
>
> Thank you and best regards
>
> Meaulnes Legler
> Zurich, Switzerland
>
> _______________________________________________
> Roundcube Users mailing list
> [hidden email]
> http://lists.roundcube.net/mailman/listinfo/users
>
> Vincent Van Houtte


Vincent Van Houtte
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: can't login after upgrade

Vincent Van Houtte
On 2018-10-08 18:15, Reindl Harald wrote:

> Am 08.10.18 um 17:14 schrieb Vincent Van Houtte:
>> These errors clearly say that the user 'arcgraph' does not exist, that
>> RC wants to create the user by logging in (I don't believe this is
>> default - an unknown user should just be rejected imho), and that the
>> subsequent attempt to create that user fails.
>>
>> There is also the mention of a plugin that may interfere here. Can you
>> disable all plugins for the sake of testing?
>
> bullshit
>
> Field 'alias' doesn't have a default value (SQL Query: INSERT INTO
> `users` (`created`, `last_login`, `username`, `mail_host`, `language`)
> VALUES (now(), now(), 'arcgraph', 'www.arcgraphics.ch', 'en_US')
>
> the table has a column 'alias' with no default value which is not
> listed
> in the insert - mysql basics

Although your assessment is correct, it misses the overall picture. The
question relates to an existing installation that was merely updated.
There is no reason why RC would need to create (INSERT INTO 'users') a
new user upon login.

Even if my suggestion would be wrong, I don't see any reason to use such
language, especially from someone dissing the lack of respect of other
people.

Kind regards,
Vincent
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: can't login after upgrade

A.L.E.C
On 10/08/2018 06:36 PM, Vincent Van Houtte wrote:
> Although your assessment is correct, it misses the overall picture. The question relates
> to an existing installation that was merely updated. There is no reason why RC would need
> to create (INSERT INTO 'users') a new user upon login.

You know nothing, John Snow ;)

@Meaulnes, the upgrade script did not fix the database structure for some reason. You have
to do this manually. Visit
https://github.com/roundcube/roundcubemail/tree/master/SQL/mysql. The files there are
named by date. You have to check all files starting from 2012080700 in order from most
recent to the oldest, until you see that the changes in the file are already in place.
Another option is to compare result of `show columns from table` command on every table
with table definitions from SQL/mysql.initial.sql file.

Your issue is quite rare, don't expect automated solution. Minimal knowledge about
database administration is required in this case.

--
Aleksander 'A.L.E.C' Machniak
Kolab Groupware Developer         [http://kolab.org]
Roundcube Webmail Developer   [http://roundcube.net]
----------------------------------------------------
PGP: 19359DC1 # Blog: https://kolabian.wordpress.com
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: can't login after upgrade

Meaulnes Legler @ roundcube

thanks all for your help! but I still didn't manage to fix this issue.

Your issue is quite rare, don't expect automated solution. Minimal knowledge about
database administration is required in this case.

that's why I'm contacting a database specialist, I'm unfortunately not very familiar with mySQL, phpMyAdmin and such...

I'll let you guys know the outcome.

Best regards

_~_
'¿')
`-´
 Meaulnes Legler
 Zurich, Switzerland
+41\0 44 260 16 60


On 08.10.18 19:40, A.L.E.C wrote:
On 10/08/2018 06:36 PM, Vincent Van Houtte wrote:
Although your assessment is correct, it misses the overall picture. The question relates
to an existing installation that was merely updated. There is no reason why RC would need
to create (INSERT INTO 'users') a new user upon login.
You know nothing, John Snow ;)
@Meaulnes, the upgrade script did not fix the database structure for some reason. You have
to do this manually. Visit
https://github.com/roundcube/roundcubemail/tree/master/SQL/mysql. The files there are
named by date. You have to check all files starting from 2012080700 in order from most
recent to the oldest, until you see that the changes in the file are already in place.
Another option is to compare result of `show columns from table` command on every table
with table definitions from SQL/mysql.initial.sql file.
Your issue is quite rare, don't expect automated solution. Minimal knowledge about
database administration is required in this case.


_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users