can't login new user

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

can't login new user

Meaulnes Legler @ roundcube

hello

I have RoundCube 1.2.4 running fine. I added the new user 'leglerlugano' on its site 'legler.org' and can access its mail thru POP3 without problems. But if I try to access the mail thru RoundCube, it seems to charge but falls immediately back to «Access failed».

In /home/.sites/xxx/xxx/web/roundcube/logs/errors, it reads:

DB Error: [1364] Field 'alias' doesn't have a default value (SQL Query: INSERT INTO `users` (`created`, `last_login`, `username`, `mail_host`, `language`) VALUES (now(), now(), 'leglerlugano', 'legler.org', 'it_IT')) in /home/.sites/xxx/xxx/web/roundcube/program/lib/Roundcube/rcube_db.php on line 539 (POST /roundcube/?_task=login&_action=login)

/var/log/maillog reads:

Sep 22 18:11:31 vs dovecot: imap-login: Login: user=<leglerlugano>, method=PLAIN, rip=94.103.99.73, lip=94.103.99.73, mpid=20684, secured, session=<fGVgAnh2supeZ2NJ>
Sep 22 18:11:31 vs dovecot: imap(leglerlugano): Logged out in=29 out=496

What alias is missing here? How can I fix this?

Thank you and best regards

_~_
'¿')
`-´
 Meaulnes Legler
 Zurich, Switzerland
+41\0 44 260 16 60


_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: can't login new user

A.L.E.C
On 09/22/2018 06:48 PM, WaveWeb - M. Legler wrote:
> DB Error: [1364] Field 'alias' doesn't have a default value (SQL Query: INSERT INTO
> `users` (`created`, `last_login`, `username`, `mail_host`, `language`) VALUES (now(),
> now(), 'leglerlugano', 'legler.org', 'it_IT')) in
> /home/.sites/xxx/xxx/web/roundcube/program/lib/Roundcube/rcube_db.php on line 539 (POST
> /roundcube/?_task=login&_action=login)

Looks like your database structure is outdated. There's no 'alias' column since Roundcube
0.8. You can just drop the column, but would be better to verify the whole structure.

--
Aleksander 'A.L.E.C' Machniak
Kolab Groupware Developer         [http://kolab.org]
Roundcube Webmail Developer   [http://roundcube.net]
----------------------------------------------------
PGP: 19359DC1 # Blog: https://kolabian.wordpress.com
_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: can't login new user

Meaulnes Legler @ roundcube
On 23.09.18 08:01, A.L.E.C wrote:
On 09/22/2018 06:48 PM, WaveWeb - M. Legler wrote:
Looks like your database structure is outdated. There's no 'alias' column since Roundcube
0.8. You can just drop the column, but would be better to verify the whole structure.

hm, don't know how to check the structure of the database... In phpMyAdmin, there are only the databases

  • avspam6
  • information_schema
  • mysql
  • nwa
  • performance_schema

and in none of them there is an «alias» column... Which one is the RoundCube database anyway?

The strange thing is that this login with subsequent immediate-logout only occurs with this new user, with other users RoundCube works fine.

Thank you and best regards

_~_
'¿')
`-´
 Meaulnes Legler
 Zurich, Switzerland
+41\0 44 260 16 60


_______________________________________________
Roundcube Users mailing list
[hidden email]
http://lists.roundcube.net/mailman/listinfo/users